A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 06:54 EAT
Identified
The issue stems from URA, and the URA Team has been notified.
Posted Mar 03, 2026 - 14:54 EAT
Update
We are continuing to investigate this issue.
Posted Mar 03, 2026 - 12:51 EAT
Investigating
All PRN generation requests are currently with the error "Unable to generate PRN at the moment. Contact IRAS if this issue persists". The team is aware of this and has informed the IRAS team, who are actively investigating the issue. Next update will be at 14:00 GMT+3